Stuck Task And Workflow Runs - Impacted By AWS Outage

Incident Report for Skyvern

Resolved

We've fully recovered
Posted Oct 20, 2025 - 22:46 UTC

Update

Skyvern Browser Sessions have recovered.

There's a long queue to process the backed up runs. It'll take 4-5 hours for us to catch up processing the agent runs in real time.
Posted Oct 20, 2025 - 22:04 UTC

Monitoring

We're seeing recoveries. Started ramping up our infrastructure to process agent runs.
Posted Oct 20, 2025 - 21:33 UTC

Update

We're still impacted by the AWS outage. All the runs are stuck at the "created" status. These runs won't be executed going forward and we're planning to cancel the stuck runs once the incident is resolved.

Sorry for the inconvenience and please reach out to us if you need any help support@skyvern.com
Posted Oct 20, 2025 - 17:52 UTC

Update

Our browsers are impacted and failing to start.
Posted Oct 20, 2025 - 08:02 UTC

Identified

The issue has been identified - aws has an outage in us-east-1 (https://health.aws.amazon.com/health/status)
Posted Oct 20, 2025 - 07:50 UTC

Update

Our task/workflow processing infrastructure is running behind due to AWS's major outage in us-east-1:
https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 07:50 UTC

Investigating

We are currently investigating this issue.
Posted Oct 20, 2025 - 07:49 UTC
This incident affected: Skyvern API, Skyvern Cloud, and Skyvern Async Workers.